当前位置: 首页 教程 正文

内存救援系统mfslinux启用IPV6 DHCP Client的办法!

阿里郎 |

https://github.com/mmatuska/mfslinux/blob/master/config/default/network

# 生成支持IPV4 & IPV6 DHCP Client 的 iso 镜像

# 安装必须得包
apt update
apt install openssl git mkisofs genisoimage make

# 同步代码
git clone https://github.com/mmatuska/mfslinux.git

# 进入 mfslinux 目录
cd mfslinux/

# 新增支持 IPV6 DHCP Client
cat <<EOF>> config/default/network
config interface ‘ipv6’
option device ‘eth0’
option proto ‘dhcpv6’
option reqaddress ‘try’
option reqprefix ‘auto’
EOF

# 增加包 不然加载 iso 进去又要安装 才能 DD 系统
cat <<EOF>> config/default/openwrt_packages_add
packages/gzip_1.10-3_x86_64.ipk
packages/pv_1.6.6-1_x86_64.ipk
packages/coreutils_8.32-6_x86_64.ipk
packages/coreutils-dd_8.32-6_x86_64.ipk
EOF

# 开始生成 iso 并设置自定义 root 密码
make ROOTPW=passwd

# 也可以用官方镜像进去之后再开IPV6
uci set network.ipv6=interface
uci set network.ipv6.device=’eth0′
uci set network.ipv6.proto=’dhcpv6′
uci set network.ipv6.reqaddress=’try’
uci set network.ipv6.reqprefix=’auto’
uci commit network
/etc/init.d/network restart

# 再安装 DD 系统必备的包
opkg update
opkg install pv
opkg install gzip
opkg install coreutils-dd

# 手动设置静态 ip 地址的办法
network.lan.ipaddr=’164.92.101.15′
network.lan.netmask=’255.255.240.0′
network.lan.gateway=’164.92.96.1′
network.lan.dns=’1.1.1.1′
network.lan.ip6addr=’2604:a880:4:1d0::622:0/64′
network.lan.ip6gw=’2604:a880:4:1d0::1′
uci commit network
/etc/init.d/network restart

尝试make失败了,有几个文件没有找到

PS:

尝试make失败了,有几个文件没有找到

PS:下载nano的时候提示错误
那就从packages/nano_6.2-2_x86_64.ipk
这里开始查地址对不对得上
发现是nano包地址被改变了(换了新包,把旧包删除了)
编辑 config/default/openwrt_packages_add 把下面这个删除就得了
packages/nano_6.2-2_x86_64.ipk
或者换成新的版本
packages/nano_6.3-1_x86_64.ipk

声明:原创文章请勿转载,如需转载请注明出处!